QuantiCode games

Zero Ballistics, Full Metal Soccer

Skip to content

Linux Mint

Post any problems related to the beta version of Zero Ballistics

Moderators: Michael, Bernhard, Christian

Linux Mint

Postby briantmc on 16 Aug 2012, 03:41

I downloaded the game and tried to run it but get this error.
How do I install and run the game ??


brian@brian-MS-7592 ~/Games/zb_20 $ ./start_client.sh
User data directory is "/home/brian/.config/QuantiCode/Zero Ballistics/"

--------------------------------------------------------------------------------
15.8.2012, 21:29:59 : log session started
Build Dec 18 2010 - 19:31:07
Debug classes: -
Version z2.00
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 260/PCIe/SSE2
GL Version: 3.3.0 NVIDIA 295.40
Max. Texture Units: 32
Max. Varying Floats: 60
Max. Vertex Attribs: 16
Max. Uniforms in VS: 4096
Max. Uniforms in FS: 2048
GLSL language version: 3.30 NVIDIA via Cg compiler
Shader Model: 4

CEGUI::Exception: DynamicModule::DynamicModule - Failed to load module 'libCEGUISILLYImageCodec.so': libjpeg.so.62: cannot open shared object file: No such file or directory
CEGUI Exception occured:DynamicModule::DynamicModule - Failed to load module 'libCEGUISILLYImageCodec.so': libjpeg.so.62: cannot open shared object file: No such file or directory
0d0h0m0.100978 Closing log.
----------------------------------------------------------------
briantmc
 
Posts: 1
Joined: 16 Aug 2012, 03:38
Location: UNITED STATES

Re: Linux Mint

Postby Michael on 20 Aug 2012, 11:09

Hi

you need to install the libjpeg62 library. Try apg-get (debian) or whatever package system you're using:

Code: Select all
sudo apt-get install libjpeg62:i386


kind regards,
Michael
Michael
Developer
 
Posts: 204
Joined: 29 Mar 2008, 17:19

Re: Linux Mint

Postby Israel on 01 Sep 2012, 00:44

Hi,
I've just downloaded the binary and I'm having the same problem (Mint 13 x64 - KDE).


CEGUI::Exception: DynamicModule::DynamicModule - Failed to load module 'libCEGUISILLYImageCodec.so': libjpeg.so.62: cannot open shared object file: No such file or directory
CEGUI Exception occured:DynamicModule::DynamicModule - Failed to load module 'libCEGUISILLYImageCodec.so': libjpeg.so.62: cannot open shared object file: No such file or directory
0d0h0m0.531618 Closing log.


$ sudo apt-get install libjpeg62
Reading package lists... Done
Building dependency tree
Reading state information... Done
libjpeg62 is already the newest version.
The following package was automatically installed and is no longer required:
python-support
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.



$ locate libjpeg.so
/usr/lib/i386-linux-gnu/libjpeg.so.8
/usr/lib/i386-linux-gnu/libjpeg.so.8.0.2
/usr/lib/x86_64-linux-gnu/libjpeg.so
/usr/lib/x86_64-linux-gnu/libjpeg.so.62
/usr/lib/x86_64-linux-gnu/libjpeg.so.62.0.0
/usr/lib/x86_64-linux-gnu/libjpeg.so.8
/usr/lib/x86_64-linux-gnu/libjpeg.so.8.0.2



Hmmm... just looking in the wrong directory maybe?? I'm very new to linux so forgive my daftness.
Israel
 
Posts: 2
Joined: 01 Sep 2012, 00:18
Location: The land of Oz

Re: Linux Mint

Postby Michael on 03 Sep 2012, 12:04

Hi

ZeroBallistics is only available in 32-bit version, therefore the correct apt-get call should be (missed that before):

Code: Select all
sudo apt-get install libjpeg62:i386


or you could try to manually download and install the i386 package from e.g. here:

http://packages.ubuntu.com/precise/i386/libjpeg62/download

kind regards,
Michael
Michael
Developer
 
Posts: 204
Joined: 29 Mar 2008, 17:19

Re: Linux Mint

Postby Israel on 03 Sep 2012, 12:24

Thanks, that fixed the problem.

Cheers.
Israel
 
Posts: 2
Joined: 01 Sep 2012, 00:18
Location: The land of Oz

Re: Linux Mint

Postby millerthegorilla on 12 Oct 2012, 14:39

Hi I have the same problem - I am running ubuntu studio 64 bit (xfce win manager to ubuntu).

As it is a 64 bit platform do I have to install all the 32 bit libraries or can I just install that one?

I'm really writing to see if anyone has had any luck or got any plans to make it compile for 64 bit?

Cheers
millerthegorilla
 
Posts: 1
Joined: 12 Oct 2012, 14:34
Location: jersey

Re: Linux Mint

Postby Michael on 16 Oct 2012, 07:57

Hi

If you downloaded the precompiled version you need the 32 bit libraries. If you want to compile it on 64-bit feel free to do so but it won't work out of the box as it was never developed under 64-bit, but sharing your experience here would be great.

kind regards,
Michael
Michael
Developer
 
Posts: 204
Joined: 29 Mar 2008, 17:19

Re: Linux Mint

Postby Vlad123 on 23 Nov 2015, 19:11

How to start the installation?
Vlad123
 
Posts: 1
Joined: 21 Nov 2015, 22:02
Location: Italy


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest


cron